Administrator Guide

1276 VRF
First, create the VLAN instances associated to the VRF. It is recommended
that a VLAN numbering scheme be developed to allow for future growth and
to assist in the easy recognition of which VLANs are associated to which
VRFs.
1
In global config mode, create the pool of VLANs:
console#config
console(config)#vlan 100-109
console(config-vlan100-109)#exit
2
Assign the VLAN to an interface:
console(config)#interface gi1/0/1
console(config-if-Gi1/0/1)#switchport access vlan 100
console(config-if-Gi1/0/1)#exit
3
Create the VRF and enable routing:
console(config)#ip vrf red
console(config-vrf-red)#ip routing
console(config-vrf-red)#exit
4
Assign IP addresses to the interfaces:
console(config)#interface vlan 100
console(config-if-vlan100)#ip address 192.168.0.1 /24
5
Put the VLAN interface into the VRF:
console(config-if-vlan100)#ip vrf forwarding red
Routing interface moved from Default router instance to red
router instance.
console(config-if-vlan100)#exit
6
Enable OSPF on the VRF, assign a network and enable OSPF for the VRF:
console(config)#router ospf vrf red
console(Config-router-vrf-red)#network 192.168.0.0
255.255.255.0 area 0
console(Config-router-vrf-red)#router-id 192.168.0.253
console(Config-router-vrf-red)#redistribute connected
console(Config-router-vrf-red)#enable
console(Config-router-vrf-red)#exit
Use the show ip ospf vrf command to view the configuration of the VRF:
console(config)#show ip ospf vrf red
Router ID...................................... 192.168.0.253