Users Guide

1426 BGP
R2(config-router-af)#redistribute static
R2(config-router-af)#exit
13
Advertise the VPNv4 routes (30.30.30.0/24). These routes are transmitted
with the extended community attribute (2020:1).
R2(config-router)#address-family vpnv4 unicast
R2(config-router-af)#neighbor 172.16.10.1 send-community both
R2(config-router-af)#neighbor 172.16.10.1 activate
R2(config-router-af)#exit
R2(config-router)#exit
R2(config)#exit
Router R3 Configuration
1
Configure a VLAN for connection to R1.
console#configure
console(config)#vlan 200
console(config-vlan200)#exit
console(config)#hostname "R3"
2
Create a loopback for the BGP router ID.
R3(config)#interface loopback 0
R3(config-if-loopback0)#ip address 11.11.11.11 255.255.255.255
R3(config-if-loopback0)#exit
3
Disable domain lookup.
R3(config)#no ip domain-lookup
4
Create a routed VLAN for connection to R1.
R3(config)#interface vlan 200
R3(config-if-vlan200)#ip address 192.168.100.11 255.255.255.0
R3(config-if-vlan200)#exit
5
Attach a physical interface to the VLAN.
R3(config)#interface Gi1/0/16
R3(config-if-Gi1/0/16)#switchport access vlan 200
R3(config-if-Gi1/0/16)#exit
6
Create an iBGP router.
R3(config)#router bgp 6500
R3(config-router)#bgp log-neighbor-changes
7
Setting the router ID is mandatory.
R3(config-router)#bgp router-id 11.11.11.11
8
Identify the BGP neighbor.