Administrator Guide

Layer 3 Routing Commands 1497
static route command along with the next hop IP address, the switch can
correctly install static route entries for unnumbered-peers. It is also possible
to configure ‘unnumbered interface routes’ where the next hop IP address is
not specified and only the unnumbered nexthop interface is configured.
Examples
Route Leaking Example 1
The following shows the configuration for VRF red-1 configured in VLAN 10.
A static global route for the 172.16.0.0 with a next hop of 172.16.0.2 is
injected into VRF red-1.
configure
vlan 10
exit
ip vrf red-1
ip routing
exit
ip routing
ip route vrf red-1 172.16.0.0 255.240.0.0 172.16.0.2
interface vlan 1
ip address 172.16.0.1 255.240.0.0
exit
interface vlan 10
ip vrf forwarding red-1
ip address 192.168.0.1 255.255.255.0
ip ospf area 0
exit
router ospf vrf “red-1”
router-id 1.1.1.1
network 192.168.0.0 0.0.0.255 area 0
exit
!
interface Gi1/0/1
switchport mode trunk
switchport access vlan 10
exit
!
interface loopback 0
ip vrf forwarding red-1
ip address 1.1.1.1 255.255.255.255
exit