Users Guide

1402 BGP
BGP Redistribution of OSPF Example
The following configuration uses the redistribute command to inject received
eBGP routes into the BGP routing table.
Interface Te1/0/1 is configured in trunk mode with a native VLAN 10 and
VLAN 10 is assigned an IP address with a /30 subnet. BGP fast fallover is
enabled for VLAN 10.
IP routing is enabled and a default route is configured that points to the
neighbor router. BGP router 3434 is created with a router ID of 172.16.64.1.
An eBGP neighbor 216.31.219.19 is configured. Private AS numbers are
stripped before distribution to this neighbor.
The router is configured to redistribute static and OSPF type 1 & type 2
external routes. Internal and connected routes are not redistributed. An
alternative to the redistribute command is to use the network command.
console#configure
console(config)#vlan 10
console(config-vlan)#exit
console(config)#interface te1/0/1
console(config-if-te1/0/1)#switchport mode trunk
console(config-if-te1/0/1)#switchport trunk native vlan 10
console(config-if-te1/0/1)#exit
console(config)#ip routing
console(config)#interface vlan 10
console(config-if-vlan10)#ip address 172.16.65.1 /30
console(config-if-vlan10)#ip bgp fast-external-fallover permit
console(config-if-vlan10)#exit
console(config)#ip route 0.0.0.0 0.0.0.0 172.16.65.2 name 'Default-
Route'
console(config)#router bgp 3434
console(config-router)#bgp router-id 172.16.64.1
console(config-router)#neighbor 216.31.219.19 remote-as 1402
console(config-router)#neighbor 216.31.219.19 remove-private-as
console(config-router)#redistribute static
console(config-router)#redistribute ospf match external 1
console(config-router)#redistribute ospf match external 2
console(config-router)#exit