Users Guide

Table Of Contents
BGP 1435
Network Example
The following configuration uses the network command to inject received
iBGP routes into the BGP routing table. The network mask allows sub-
netting and super-netting. An alternative to the network command is to use
the redistribute command.
Interface Gi1/0/1 is configured as a member of VLAN 10, VLAN 10 is assigned
an IP address, IP routing is enabled, and BGP router 65001 is created with a
router ID of 129.168.1.254. A static subnet route 129.168.0.X is created for
VLAN 10. An iBGP neighbor 129.168.0.254 is configured and the network
129.168.x.X is configured to super-net the 129.168.0.x advertisement. The
neighbor state is configured to follow loopback 0.
console#configure
console(config)#vlan 10
console(config-vlan)#exit
console(config)#interface gi1/0/1
console(config-if-Gi1/0/1)#switchport access vlan 10
console(config-if-Gi1/0/1)#exit
console(config)#interface vlan 10
console(config-if-vlan10)#ip address 129.168.10.2 /24
console(config-if-vlan10)#exit
console(config)#int loopback 0
console(config-if-loopback0)#ip address 129.168.1.254 /24
console(config-if-loopback0)#exit
console(config)#ip routing
console(config)#router bgp 65001
console(config-router)#bgp router-id 129.168.1.254
console(config-router)#neighbor 129.168.0.254 remote-as 65001
console(config-router)#neighbor 129.168.0.254 update-source
loopback 0
console(config-router)#network 129.168.0.0 mask 255.255.0.0
console(config-router)#exit