Users Guide

BGP 1425
3
Disable domain lookup and enable IP routing.
R2(config)#no ip domain-lookup
R2(config)#ip routing
4
Create a loopback for the BGP router.
R2(config)#interface loopback 0
R2(config-if-loopback0)#ip address 20.20.20.20 255.255.255.255
R2(config-if-loopback0)#exit
5
Create a loopback to emulate a subnet in the VRF. This could be assigned
to a real VLAN.
R2(config)#interface loopback 1
R2(config-if-loopback1)#ip vrf forwarding WAN
R2(config-if-loopback1)#ip address 30.30.30.30 255.255.255.0
R2(config-if-loopback1)#exit
6
VLAN 100 is connected to R1.
R2(config)#interface vlan 100
R2(config-if-vlan100)#ip address 172.16.10.2 255.255.255.0
R2(config-if-vlan100)#exit
7
Assign the physical connection to R1.
R2(config)#interface Gi1/0/13
R2(config-if-Gi1/0/13)#switchport access vlan 100
R2(config-if-Gi1/0/13)#exit
8
Configure a BGP router with as 6500.
R2(config)#router bgp 6500
R2(config-router)#bgp log-neighbor-changes
9
Use the loopback for the router ID. The router ID is required.
R2(config-router)#bgp router-id 20.20.20.20
10
Redistribute connected subnets.
R2(config-router)#redistribute connected
11
R1 is an eBGP connection.
R2(config-router)#neighbor 172.16.10.1 remote-as 5500
R2(config-router)#neighbor 172.16.10.1 send-community
12
Advertise the IPv4 routes in VRF WAN (20.20.20.20/32 and
172.16.10.0/24).
R2(config-router)#address-family ipv4 vrf WAN
R2(config-router-af)#neighbor 172.16.10.1 remote-as 5500
R2(config-router-af)#redistribute connected