Users Guide

1450 BGP
7
Emulate a network in the Green VRF. The loopback network can be
replaced with a VLAN-routed interface.
S2(config)#interface loopback 17
S2(config-if-loopback17)#ip vrf forwarding Green
S2(config-if-loopback17)#ip address 172.17.2.1 255.255.255.0
S2(config-if-loopback17)#exit
8
Create a VLAN routed interface to router S1 for VRF Red.
S2(config)#interface vlan 16
S2(config-if-vlan16)#ip vrf forwarding Red
S2(config-if-vlan16)#ip address 172.16.0.2 255.255.255.0
S2(config-if-vlan16)#exit
9
Create a VLAN routed interface to router S1 for VRF Green.
S2(config)#interface vlan 17
S2(config-if-vlan17)#ip vrf forwarding Green
S2(config-if-vlan17)#ip address 172.17.0.2 255.255.255.0
S2(config-if-vlan17)#exit
10
Assign VLANs to a trunk.
S2(config)#interface Gi1/0/13
S2(config-if-Gi1/0/13)#switchport mode trunk
S2(config-if-Gi1/0/13)#switchport trunk allowed vlan 1,16-17
S2(config-if-Gi1/0/13)#exit
S3 is configured almost identically to S2 with the exception that VRF Green
is not configured on S2.
1
Create VLANs and configure the hostname for S3.
console#configure
console(config)#vlan 16,18
console(config-vlan)#exit
console(config)#hostname "S3"
2
Configure VRF Blue. Same RD as on S1 and S2.
S3(config)#ip vrf Blue
S3(config-vrf-Blue)#rd 65000:3
S3(config-vrf-Blue)#exit
3
Configure VRF Red. Same RD as on S1 and S2.
S3(config)#ip vrf Red
S3(config-vrf-Red)#rd 65000:1
S3(config-vrf-Red)#exit
S3(config)#no ip domain-lookup