Users Guide

ToR2(conf-if-eth1/1/1)# exit
ToR2(config)# interface ethernet1/1/2
ToR2(conf-if-eth1/1/2)# description ToR2-Leaf4
ToR2(conf-if-eth1/1/2)# no switchport
ToR2(conf-if-eth1/1/2)# mtu 9216
ToR2(conf-if-eth1/1/2)# ip address 10.6.1.1/31
ToR2(conf-if-eth1/1/2)# exit
2. Configure a VLAN interface and a VLAN member for end devices.
ToR2(config)# interface vlan 2001
ToR2(conf-if-vl-2001)# ip address 172.16.2.1/24
ToR2(conf-if-vl-2001)# mtu 9216
ToR2(conf-if-vl-2001)# exit
ToR2(config)# interface ethernet1/1/3
ToR2(conf-if-eth1/1/3)# description ToR2-Hosts
ToR2(conf-if-eth1/1/3)# mtu 9216
ToR2(conf-if-eth1/1/3)# switchport mode trunk
ToR2(conf-if-eth1/1/3)# switchport trunk allowed vlan 2001
ToR2(conf-if-eth1/1/3)# exit
3. Configure BGP neighbors, and advertise the host subnet.
ToR2(config)# router bgp 65302
ToR2(config-router-bgp-65302)# router-id 10.0.2.2
ToR2(config-router-bgp-65302)# address-family ipv4 unicast
ToR2(configure-router-bgpv4-af)# network 172.16.2.0/24
ToR2(configure-router-bgpv4-af)# exit
ToR2(config-router-bgp-65302)# neighbor 10.5.1.0
ToR2(config-router-neighbor)# remote-as 65202
ToR2(config-router-neighbor)# no shutdown
ToR2(config-router-neighbor)# exit
ToR2(config-router-bgp-65302)# neighbor 10.6.1.0
ToR2(config-router-neighbor)# remote-as 65202
ToR2(config-router-neighbor)# no shutdown
ToR2(config-router-neighbor)# exit
Debug BGP
Use the following procedure to debug BGP.
To debug BGP:
debug ip bgp
Configuring BGP template
Configure the BGP templates to support the following attributes in IPv4 and IPv6 address family level: next-hop-self, oft-
reconfiguration inbound, maximum-prefix, and add-path.
To configure BGP template:
1. Configure peer-group under BGP.
OS10(config)# router bgp 100
OS10(config-router-bgp-100)# template abc
2. Configure maximum-prefix in IPV4 AFI, where maximum-prefix is 10, threshold is 50, and warning is enabled.
OS10(config-router-template)# address-family ipv4 unicast
OS10(config-router-bgp-template-af)# maximum-prefix 10 50 warning-only
834
Layer 3