Administrator Guide

Route maps add to that redistribution capability by allowing you to match specic routes and set or change more attributes when
redistributing those routes.
In the following example, the redistribute command calls the route map static ospf to redistribute only certain static routes into
OSPF. According to the route map static ospf, only routes that have a next hop of Tengigabitethernet interface 1/1 and that have a
metric of 255 are redistributed into the OSPF backbone area.
NOTE: When re-distributing routes using route-maps, you must create the route-map dened in the redistribute command
under the routing protocol. If you do not create a route-map, NO routes are redistributed.
Example of Calling a Route Map to Redistribute Specied Routes
router ospf 34
default-information originate metric-type 1
redistribute static metric 20 metric-type 2 tag 0 route-map staticospf
!
route-map staticospf permit 10
match interface GigabitEthernet 1/1
match metric 255
set level backbone
Congure a Route Map for Route Tagging
One method for identifying routes from dierent routing protocols is to assign a tag to routes from that protocol.
As the route enters a dierent routing domain, it is tagged. The tag is passed along with the route as it passes through dierent routing
protocols. You can use this tag when the route leaves a routing domain to redistribute those routes again. In the following example, the
redistribute ospf command with a route map is used in ROUTER RIP mode to apply a tag of 34 to all internal OSPF routes that are
redistributed into RIP.
Example of the redistribute Command Using a Route Tag
!
router rip
redistribute ospf 34 metric 1 route-map torip
!
route-map torip permit 10
match route-type internal
set tag 34
!
Continue Clause
Normally, when a match is found, set clauses are executed, and the packet is then forwarded; no more route-map modules are processed.
If you congure the continue command at the end of a module, the next module (or a specied module) is processed even after a match
is found. The following example shows a continue clause at the end of a route-map module. In this example, if a match is found in the
route-map “test” module 10, module 30 is processed.
NOTE
: If you congure the continue clause without specifying a module, the next sequential module is
processed.
Example of Using the continue Clause in a Route Map
!
route-map test permit 10
match commu comm-list1
set community 1:1 1:2 1:3
set as-path prepend 1 2 3 4 5
continue 30!
116
Access Control Lists (ACLs)