Connectivity Guide

13. Congure IP switching in the overlay network
Create a tenant VRF
OS10(config)# ip vrf tenant1
OS10(conf-vrf)# exit
Congure an anycast gateway MAC address
OS10(config)# ip virtual-router mac-address 00:01:01:01:01:01
Congure routing on the virtual networks
OS10(config)# interface virtual-network10000
OS10(conf-if-vn-10000)# ip vrf forwarding tenant1
OS10(conf-if-vn-10000)# ip address 10.1.0.231/16
OS10(conf-if-vn-10000)# ip virtual-router address 10.1.0.100
OS10(conf-if-vn-10000)# no shutdown
OS10(conf-if-vn-10000)# exit
OS10(config)# interface virtual-network20000
OS10(conf-if-vn-20000)# ip vrf forwarding tenant1
OS10(conf-if-vn-20000)# ip address 10.2.0.231/16
OS10(conf-if-vn-10000)# ip virtual-router address 10.2.0.100
OS10(conf-if-vn-20000)# no shutdown
OS10(conf-if-vn-20000)# exit
VTEP 2 Leaf Switch
1. Congure a Loopback interface for the VXLAN underlay using the same IP address as the VLT peer
OS10(config)# interface loopback0
OS10(conf-if-lo-0)# no shutdown
OS10(conf-if-lo-0)# ip address 192.168.1.1/32
OS10(conf-if-lo-0)# exit
2. Congure the Loopback interface as the VXLAN source tunnel interface
OS10(config)# nve
OS10(config-nve)# source-interface loopback0
OS10(config-nve)# exit
3. Congure the VXLAN virtual networks
OS10(config)# virtual-network 10000
OS10(config-vn)# vxlan-vni 10000
OS10(config-vn-vxlan-vni-10000)# exit
OS10(config-vn)# exit
OS10(config)# virtual-network 20000
OS10(config-vn)# vxlan-vni 20000
OS10(config-vn-vxlan-vni-20000)# exit
OS10(config-vn)# exit
4. Assign VLAN member interfaces to the virtual networks
Use a switch-scoped VLAN-to-VNI mapping:
OS10(config)# interface vlan100
OS10(config-if-vl-100)# virtual-network 10000
OS10(config-if-vl-100)# no shutdown
OS10(config-if-vl-100)# exit
OS10(config)# interface vlan200
OS10(config-if-vl-200)# virtual-network 20000
OS10(config-if-vl-200)# no shutdown
OS10(config-if-vl-200)# exit
746
VXLAN