Connectivity Guide

Table Of Contents
5 Assign an IP address to the interface in INTERFACE mode.
ip address ip-address/mask
6 Enable OSPFv2 on an interface in INTERFACE mode.
ip ospf process-id area area-id
process-id—Enter the OSPFv2 process ID for a specic OSPF process, from 1 to 65535.
area-id—Enter the OSPFv2 area ID as an IP address (A.B.C.D) or number, from 1 to 65535.
Enable OSPFv2 conguration
OS10(config)# router ospf 100
OS10(conf-router-ospf-100)# exit
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# no switchport
OS10(conf-if-eth1/1/1)# ip address 11.1.1.1/24
OS10(conf-if-eth1/1/1)# ip ospf 100 area 0.0.0.0
View OSPFv2 conguration
OS10# show running-configuration ospf
!
interface ethernet1/1/1
ip ospf 100 area 0.0.0.0
!
router ospf 100
...
Enable OSPFv2 in a non-default VRF instance
To enable OSPFv2 in a non-default VRF instance:
1 Create a non-default VRF instance in which you want to enable OSPFv2:
ip vrf vrf-name
2 Enable OSPF and congure an OSPF instance in VRF CONFIGURATION mode.
router ospf instance-number vrf vrf-name
3 Enter the interface information to congure the interface for OSPF in INTERFACE mode.
interface ethernet node/slot/port[:subport]
4 Enable the interface in INTERFACE mode.
no shutdown
5 Disable the default switchport conguration and remove it from an interface or a LAG port in INTERFACE mode.
no switchport
6 Associate the interface with the non-default VRF instance that you created earlier.
ip vrf forwarding vrf-name
7 Assign an IP address to the interface.
ip address ip-address/mask
8 Enable OSPFv2 on the interface.
ip ospf process-id area area-id
process-id—Enter the OSPFv2 process ID for a specic OSPF process, from 1 to 65535.
area-id—Enter the OSPFv2 area ID as an IP address (A.B.C.D) or number, from 1 to 65535.
Enable OSPFv2 conguration
OS10(config)# ip vrf vrf-blue
OS10(config-vrf-blue)# router ospf 100 vrf-blue
OS10(conf-router-ospf-100)# exit
OS10(config)# interface ethernet 1/1/2
OS10(conf-if-eth1/1/2)# no shutdown
436
Layer 3