Concept Guide

seq 5 permit any dscp 50 ecn 1
seq 10 permit any dscp 50 ecn 2
seq 15 permit any dscp 50 ecn 3
!
ip access-list standard dscp_40_ecn
seq 5 permit any dscp 40 ecn 1
seq 10 permit any dscp 40 ecn 2
seq 15 permit any dscp 40 ecn 3
!
ip access-list standard dscp_50_non_ecn
seq 5 permit any dscp 50 ecn 0
!
ip access-list standard dscp_40_non_ecn
seq 5 permit any dscp 40 ecn 0
!
class-map match-any class_dscp_40
match ip access-group dscp_40_non_ecn set-color yellow
match ip access-group dscp_40_ecn
!
class-map match-any class_dscp_50
match ip access-group dscp_50_non_ecn set-color yellow
match ip access-group dscp_50_ecn
!
policy-map-input pmap_dscp_40_50
service-queue 2 class-map class_dscp_40
service-queue 3 class-map class_dscp_50
Applying Layer 2 Match Criteria on a Layer 3 Interface
To process Layer 3 packets that contain a dot1p (IEEE 802.1p) VLAN Layer 2 header, congure VLAN tags on a Layer 3 port interface
which is congured with an IP address but has no VLAN associated with it. You can also congure a VLAN sub-interface on the port
interface and apply a policy map that classies packets using the dot1p VLAN ID.
To apply an input policy map with Layer 2 match criteria to a Layer 3 port interface, use the service-policy input policy-name
layer 2
command in Interface conguration mode.
To apply a Layer 2 policy on a Layer 3 interface:
1 Congure an interface with an IP address or a VLAN sub-interface
CONFIGURATION mode
DellEMC(conf)# interface fo 1/49/1
INTERFACE mode
DellEMC(conf-if-fo-1/49/1)# ip address 90.1.1.1/16
2 Congure a Layer 2 QoS policy with Layer 2 (Dot1p or source MAC-based) match criteria.
CONFIGURATION mode
DellEMC(conf)# policy-map-input l2p layer2
3 Apply the Layer 2 policy on a Layer 3 interface.
INTERFACE mode
DellEMC(conf-if-fo-1/49/1)# service-policy input l2p layer2
Quality of Service (QoS)
813