Reference Guide

Directory contents for folder: home
Date (modified) Size (bytes) Name
--------------------- ------------ ------------------------------------------
2017-02-15T19:25:35Z 77
b.cmd
...
Execute the batch le using the batch command in EXEC mode.
OS10# batch b.cmd
OS10# Feb 15 19:26:1: %Dell EMC (OS10) %Node.1-Unit.1:PRI:OS10 %log-notice:IP_ADDRESS_ADD: IP
Address add is successful.:IP 172.17.4.1/24 added successfully
(Optional) Verify the new commands in the running conguration.
OS10# show running-configuration interface ethernet 1/1/4
!
interface ethernet1/1/4
ip address 172.17.4.1/24
no switchport
no shutdown
Linux shell commands
You can execute a single command, or a series of commands using a batch le from the Linux shell.
Use the -c option to run a single command.
admin@OS10:/opt/dell/os10/bin$ clish -c "show version"
New user admin logged in at session 10
OS10# show version
Dell EMC Networking OS10 Enterprise
Copyright (c) 1999-2017 by Dell Inc. All Rights Reserved.
OS Version: 10.3.9999E(X)
Build Version: 10.3.9999E(X.6309)
Build Time: 2017-12-28T18:07:44-0800
System Type: S4048-ON
Architecture: x86_64
Up Time: 1 week 4 days 08:07:44
User admin logged out at session 10
admin@OS10:/opt/dell/os10/bin$
Use the -B option along with a batch le to execute a series of commands.
configure terminal
router bgp 100
neighbor 100.1.1.1
remote-as 104
no shutdown
Execute the batch le.
admin@OS10:/opt/dell/os10/bin$ clish -B ~/batch_cfg.txt
New user admin logged in at session 15
Verify the BGP conguration executed by the batch le.
admin@OS10:/opt/dell/os10/bin$ clish -c "show running-configuration bgp"
New user admin logged in at session 16
!
router bgp 100
!
neighbor 100.1.1.1
remote-as 104
Getting Started
43