Users Guide

<VRF Name of the interface> : <VLANname>-<Portname>
e.g.: RED:vlan200-ethernet1/1/2
Both Host name and VRF Name as prefix :
<Host name>-<VRF Name of the interface> : <VLANID>-<Portname>
e.g.: DELL OS10-RED:vlan200-ethernet1/1/2
CLI Configuration:
DHCP Relay Agent:
Global config:
ipv6 dhcp-relay interface-id
ipv6 dhcp-relay prefix interface-id hostname
ipv6 dhcp-relay hostname DELL
OS10#show running-configuration
interface Ethernet 1/1/1
no shutdown
switchport mode trunk
switch port trunk allowed vlan 10
ipv6 dhcp-relay interface-id description PORT
!
interface vlan 10
no shutdown
ip address 1.1.1.1/24
ip helper-address 20.1.1.2
ipv6 dhcp-relay interface-id description VLAN
!
interface Ethernet 1/1/2
no shutdown
ip address 20.1.1.1
!
DHCP Server
OS10(config)# ip dhcp server
OS10(config-dhcp)# pool dell_1
OS10(config-dhcp-dell_1)# network 10.1.1.0/24
OS10(config-dhcp-dell_1)# range 10.1.1.2 10.1.1.10
OS10(config-dhcp-dell_1)# default-router 10.1.1.1
OS10(config-dhcp-dell_1)# end
OS10(config-dhcp)# pool dell_2
OS10(config-dhcp-dell_2)# network 20.1.1.0/24
OS10(config-dhcp-dell_2)# range 20.1.1.2 20.1.1.10
OS10(config-dhcp-dell_2)# default-router 20.1.1.1
OS10(config-dhcp-dell_2)# end
OS10#show running-config ip dhcp
!
ip dhcp server
!
ip dhcp pool dell_1
network 10.1.1.0/24
default-router 10.1.1.1
address range 10.1.1.2 10.1.1.10
ip dhcp pool dell_2
network 20.1.1.0/24
default-router 20.1.1.1
address range 20.1.1.2 20.1.1.10
In this scenario, the interface-id value: DELL:VLAN-PORT is added in the packet and sent out of DHCPv6 relay agent. You can
configure the DHCP server to allocate an IP address from a range of IP addresses based on the interface-id value that is
received from the DHCPv6 packet. The prefix value is configured to take hostname: DELL(DHCPv6 hostname) and interface
description is configured in both the VLAN and physical interface (VLAN and PORT).
System management
295