Users Guide

neighbor
Creates a remote IP or unnumbered peer and enters Neighbor Configuration mode.
Syntax
neighbor {ip-address | interface interface-type | unnumbered-auto}
Parameters
ip-addressEnter the IPv4 or IPv6 address of the neighbor.
interface interface-typeEnter the interface that connects to an unnumbered neighbor.
unnumbered-autoConfigure one or more BGP auto unnumbered neighbors.
Default Not configured
Command Mode CONFIG-ROUTER-BGP
Usage
Information
Create a remote peer with the BGP neighbor.
If you configure an unnumbered interface using the interface, or unnumbered-auto options, ensure
that the interface is in Layer 3 mode. Also, enable Router Advertisement globally or on required interfaces
using the ipv6 nd send-ra command. If you do not enable Router Advertisement, the BGP
neighborship does not form. Dell EMC networking recommends configuring the minimum and maximum
advertisement intervals as 3 s and 4 s, respectively.
NOTE: You cannot configure the default VLAN as the connecting interface for an unnumbered
neighbor.
NOTE: To configure these settings for a nondefault VRF instance, you must first enter the ROUTER-
CONFIG-VRF sub mode using the following commands:
1. Enter the ROUTER BGP mode using the router bgp as-number command.
2. From the ROUTER BGP mode, enter the ROUTER BGP VRF mode using the vrf vrf-name
command.
The
no version of this command disables the BGP neighbor configuration.
Example
The following is an example for configuring an unnumbered BGP neighbor:
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# ipv6 nd max-ra-interval 4
OS10(conf-if-vl-100)# ipv6 nd min-ra-interval 3
OS10(conf-if-vl-100)# ipv6 nd send-ra
OS10(conf-if-vl-100)# exit
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# switchport mode trunk
OS10(conf-if-eth1/1/1)# switchport trunk allowed vlan 100
OS10(config)# router bgp 100
OS10(config-router-bgp-100)# neighbor interface vlan 100
OS10(config-router-neighbor)# no shutdown
The following is an example for configuring an auto unnumbered BGP neighbor:
OS10# configure terminal
OS10(config)# ipv6 nd max-ra-interval 4
OS10(config)# ipv6 nd min-ra-interval 3
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# no switchport
OS10(conf-if-eth1/1/1)# ipv6 nd send-ra
OS10(conf-if-eth1/1/1)#ipv6 bgp unnumbered ebgp-template
OS10(conf-if-eth1/1/1)#exit
OS10(config)# router bgp 100
OS10(config-router-bgp-100)# neighbor unnumbered-auto
OS10(config-router-neighbor)# no shutdown
Supported
Releases
10.3.0E or later
856 Layer 3