API Guide

Create a tenant VRF.
OS10(config)# ip vrf tenant1
OS10(conf-vrf)# exit
Configure an anycast gateway MAC address.
OS10(config)# ip virtual-router mac-address 00:01:01:01:01:01
Configure routing on the virtual network.
OS10(config)# interface virtual-network 20000
OS10(conf-if-vn-20000)# ip vrf forwarding tenant1
OS10(conf-if-vn-20000)# ip address 10.2.0.234/16
OS10(conf-if-vn-20000)# ip virtual-router address 10.2.0.100
OS10(conf-if-vn-20000)# no shutdown
OS10(conf-if-vn-20000)# exit
13. Configure symmetric IRB. In EVPN mode, configure the router MAC address that is used by remote VTEPs as the destination address
in VXLAN encapsulated packets that are sent to the switch. Configure a dedicated VXLAN VNI for symmetric IRB for each tenant
VRF.
OS10(config)# evpn
OS10(config-evpn)# router-mac 00:01:02:03:04:06
OS10(config-evpn)# vrf tenant1
OS10(config-evpn-vrf-tenant1)# vni 3000
OS10(config-evpn-vrf-tenant1)# route-target auto
OS10(config-evpn-vrf-tenant1)# exit
OS10(config-evpn)# exit
14. Configure an externally connected VLAN.
OS10(conf)# interface vlan 200
OS10(conf-if-vlan)# ip vrf forwarding tenant1
OS10(conf-if-vlan)# ip address 10.10.0.2/16
OS10(conf-if-vlan)# no shutdown
OS10(conf-if-vlan)# exit
OS10(conf)# interface ethernet 1/1/7
OS10(conf-if-eth1/1/7)# switchport mode trunk
OS10(conf-if-eth1/1/7)# switchport trunk allowed vlan 200
15. Configure advertisement of the connected networks through EVPN Type-5 routes.
OS10(config)# evpn
OS10(config-evpn)# vrf tenant1
OS10(config-evpn-vrf-tenant1)# advertise ipv4 connected
OS10(config-evpn-vrf-tenant1)# exit
Example: Migrating from Asymmetric IRB to
Symmetric IRB
Until Release 10.5.0, OS10 provided support only for the Asymmetric IRB mode. Starting from Release 10.5.1, OS10 supports the
Symmetric IRB mode. Symmetric IRB mode efficiently uses next hop tables in the NPU. If there are no local hosts, Symmetric IRB mode
does not require creation of destination VNI in the local VTEP. You can migrate your network from Asymmetric IRB mode to Symmetric
IRB mode. For a seamless migration with less or no downtime in the VLT environment, perform the following steps:
NOTE:
Before you start this migration, all leaf nodes acting as VTEPs in the Clos network must be upgraded to 10.5.1.x.
If there are overlay hosts in default VRF, migration to Symmetric IRB mode is not supported because Symmetric IRB
mode cannot be used in default VRF.
156 BGP EVPN for VXLAN