Users Guide

Table Of Contents
interface Ethernet 1/1/1
no shutdown
switchport mode trunk
switch port trunk allowed vlan 10
ipv6 dhcp-relay interface-id description PORT
!
interface vlan 10
no shutdown
ip address 1.1.1.1/24
ip helper-address 20.1.1.2
ipv6 dhcp-relay interface-id description VLAN
!
interface Ethernet 1/1/2
no shutdown
ip address 20.1.1.1
!
DHCP Server
OS10(config)# ip dhcp server
OS10(config-dhcp)# pool dell_1
OS10(config-dhcp-dell_1)# network 10.1.1.0/24
OS10(config-dhcp-dell_1)# range 10.1.1.2 10.1.1.10
OS10(config-dhcp-dell_1)# default-router 10.1.1.1
OS10(config-dhcp-dell_1)# end
OS10(config-dhcp)# pool dell_2
OS10(config-dhcp-dell_2)# network 20.1.1.0/24
OS10(config-dhcp-dell_2)# range 20.1.1.2 20.1.1.10
OS10(config-dhcp-dell_2)# default-router 20.1.1.1
OS10(config-dhcp-dell_2)# end
OS10#show running-config ip dhcp
!
ip dhcp server
!
ip dhcp pool dell_1
network 10.1.1.0/24
default-router 10.1.1.1
address range 10.1.1.2 10.1.1.10
ip dhcp pool dell_2
network 20.1.1.0/24
default-router 20.1.1.1
address range 20.1.1.2 20.1.1.10
In this scenario, the interface-id value: DELL:VLAN-PORT is added in the packet and sent out of DHCPv6 relay agent. You
can configure the DHCP server to allocate an IP address from a range of IP addresses based on the interface-id value that is
received from the DHCPv6 packet. The prefix value is configured to take hostname: DELL(DHCPv6 hostname) and interface
description is configured in both the VLAN and physical interface (VLAN and PORT).
Parameter assignment based on Remote-ID option
In this scenario, there are two DHCPv6 relay agents that are connected to the VLT peers. The hosts that are connected
to the two DHCPv6 relay agents belong to different VLANs that are part of different VRFs. The link address subnet in the
DHCPv6 RELAY-FORWARD message from either of the DHCPv6 relay agents can be the same. The IPv6 address range and the
configuration parameters for the hosts connected to different DHCPv6 relay agents are managed by the administrator based on
the remote-ID option value in the DHCPv6 relay agent.
System management
279