Connectivity Guide

Table Of Contents
VTEP 1 Leaf Switch
1. Congure a loopback interface
OS10(config)# interface loopback0
OS10(conf-if-lo-0)# ip address 1.1.1.1/32
OS10(conf-if-lo-0)# exit
2. Congure the loopback interface as the VXLAN source tunnel interface
OS10(config)# nve
OS10(config-nve)# source-interface loopback0
OS10(config-nve)# exit
3. Congure eBGP for the IPv4 address family and advertise the VTEP's loopback IP address
OS10(config)# router bgp 65002
OS10(config-router-bgp-65002)# address-family ipv4 unicast
OS10(configure-router-bgpv4-af)# network 1.1.1.1/32
OS10(configure-router-bgpv4-af)# exit
OS10(config-router-bgp-65002)# router-id 1.1.1.1
OS10(config-router-bgp-65002)# neighbor 11.1.1.2
OS10(config-router-neighbor)# remote-as 65001
OS10(config-router-neighbor)# no shutdown
OS10(config-router-neighbor)# address-family ipv4 unicast
OS10(config-router-bgp-neighbor-af)# allowas-in 1
OS10(config-router-bgp-neighbor-af)# exit
OS10(config-router-neighbor)# exit
OS10(config-router-bgp-65002)# neighbor 12.1.1.2
OS10(config-router-neighbor)# remote-as 65001
OS10(config-router-neighbor)# no shutdown
OS10(config-router-neighbor)# address-family ipv4 unicast
OS10(config-router-bgp-neighbor-af)# allowas-in 1
OS10(config-router-neighbor)# exit
OS10(config-router-bgp-65002)# exit
4. Congure eBGP for the EVPN address family
OS10(config)# router bgp 65002
OS10(config-router-bgp-65002)# neighbor 11.11.11.11
OS10(config-router-neighbor)# remote-as 65501
OS10(config-router-neighbor)# update-source loopback 0
OS10(config-router-neighbor)# no shutdown
OS10(config-router-neighbor)# send-community extended
OS10(config-router-neighbor)# address-family ipv4 unicast
OS10(config-router-bgp-neighbor-af)# no activate
OS10(config-router-neighbor)# address-family l2vpn evpn
OS10(config-router-bgp-neighbor-af)# activate
OS10(config-router-bgp-neighbor-af)# allowas-in 1
OS10(config-router-bgp-neighbor-af)# exit
OS10(config-router-neighbor)# exit
OS10(config-router-bgp-65002)# neighbor 22.22.22.22
OS10(config-router-neighbor)# remote-as 65001
OS10(config-router-neighbor)# update-source loopback 0
OS10(config-router-neighbor)# no shutdown
OS10(config-router-neighbor)# send-community extended
OS10(config-router-neighbor)# address-family ipv4 unicast
OS10(config-router-bgp-neighbor-af)# no activate
OS10(config-router-bgp-neighbor-af)# exit
OS10(config-router-neighbor)# address-family l2vpn evpn
OS10(config-router-bgp-neighbor-af)# activate
OS10(config-router-bgp-neighbor-af)# allowas-in 1
OS10(config-router-bgp-neighbor-af)# exit
OS10(config-router-neighbor)# exit
OS10(config-router-bgp-65002)# exit
VXLAN
565