Users Guide

Table Of Contents
PBR configuration
Apply the policy on the VLTi interfaces of both VLT peers.
OS10(config)# ip access-list PBR-A2C
OS10(conf-ipv4-acl)# permit ip 10.10.10.0/24 any
OS10(conf-route-map)# route-map Map1
OS10(conf-route-map)# match ip address PBR-A2C
OS10(conf-route-map)# set ip next-hop 10.10.20.10
OS10(conf-route-map)# exit
OS10(config)# interface ethernet 1/1/4-1/1/6
OS10(conf-if-eth1/1/4-1/1/6)# ip policy route-map Map1
Sample configuration
Consider a scenario where traffic from source IP address 1.1.1.1 ingresses through VLAN40 that is part of VRF RED. The egress
interface for this traffic is also on the same VRF RED with IP address 4.4.4.4, as shown.
Using the following PBR configuration, you can re-direct traffic ingresssing to VRF RED to a destination that is reachable
through the next-hop IP address 2.2.2.2 in VRF BLUE:
1. Create a route-map.
OS10(config)# route-map test
2. Enter the IP address to match the specified access list.
OS10(config-route-map)# match ip 4.4.4.4 acl1
3. Set the next-hop address to 2.2.2.2, which is reachable through VRF BLUE.
OS10(config-route-map)#
OS10(config-route-map)# set ip vrf BLUE next-hop 2.2.2.2
OS10(config-route-map)# exit
4. Apply this rule to the interface where the traffic ingresses, in this case VLAN40.
OS10(config)# interface vlan 40
OS10(conf-if-vl-40)#
OS10(conf-if-vl-40)# ip policy route-map test
5. (Optional) View the PBR configuration on the interface.
OS10(conf-if-vl-40)# show configuration
!
interface vlan40
no shutdown
ip policy route-map test
!
Layer 3
807