Reference Guide

Table Of Contents
ERPM does not work on VLT devices.
RPM on VLT scenarios
Consider a simple VLT setup where two VLT devices are connected using VLTi and a top-of-rack (TOR) switch is connected to
both the VLT peers using VLT LAGs in a ring topology. In this setup, the following table describes the possible scenarios when
RPM is used to mirror traffic.
NOTE: The ports that are connected to the VLT domain, but not part of the VLT-LAG, are called orphan ports.
Table 2. RPM on VLT scenarios
Scenario Recommendation
Mirror an orphan port or VLT LAG or VLTi member port
to VLT LAG. The packet analyzer is connected to the TOR
switch.
The following is an example of recommended configuration on
the peer VLT device:
1. Create RPM VLAN
!
interface vlan 100
no shutdown
remote-span
!
2. Create an L2 ACL for the RPM VLAN - RPM session and
attach it to VLTi LAG interface.
!
mac access-list rpm
seq 10 permit any any capture session
10 vlan 100
!
interface ethernet 1/1/1
no shutdown
switchport access vlan 1
mac access-group rpm in
!
3. Create a flow based RPM session on the peer VLT device
to monitor the VLTi LAG interface as source.
!
monitor session 10 type rpm-source
destination remote-vlan 100
flow-based enable
source interface ethernet1/1/1 (ICL
lag member)
!
Mirror a VLAN with VLTi LAG as member to any orphan port
on the same VLT device. The packet analyzer is connected to
the local VLT device through the orphan port.
The following is an example of recommended configuration on
the VLT device:
1. Create an L2 ACL for the local session and attach it to the
VLTi LAG interface.
!
mac access-list local
seq 10 permit any any capture session
10
!
interface ethernet 1/1/1
no shutdown
switchport access vlan 1
mac access-group local in
!
248 Layer 2