API Guide

Create a VLAN.
OS10# configure terminal
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# no shutdown
VLT configuration
1. Create a VLT domain and configure VLTi.
OS10(config)# interface range ethernet 1/1/4-1/1/5
OS10(conf-range-eth1/1/4-1/1/5)# no switchport
OS10(conf-range-eth1/1/4-1/1/5)# exit
OS10(config)# vlt-domain 1
OS10(conf-vlt-1)# discovery-interface ethernet 1/1/4-1/1/5
2. Configure a VLT MAC address.
OS10(conf-vlt-1)# vlt-mac 12:5e:23:f4:23:54
3. Specify the management IP address of the VLT peer as a backup link.
OS10(conf-vlt-1)# backup destination 10.10.10.1
4. Configure VLT port channels.
VLT port channel to VM
OS10(config)# interface port-channel 10
OS10(conf-if-po-10)# description SW2ToVM
OS10(conf-if-po-10)# vlt-port-channel 10
OS10(conf-if-po-10)# switchport mode access
OS10(conf-if-po-10)# switchport access vlan 100
OS10(conf-if-po-10)# exit
OS10(config)# interface ethernet 1/1/2-1/1/3
OS10(conf-if-eth1/1/2-1/1/3)# no shutdown
OS10(conf-if-eth1/1/2-1/1/3)# channel-group 10
VLT port channel to DHCP server
OS10(config)# interface port-channel 20
OS10(conf-if-po-20)# description SW2ToDHCP-Server
OS10(conf-if-po-20)# vlt-port-channel 20
OS10(conf-if-po-20)# switchport mode access
OS10(conf-if-po-20)# switchport access vlan 100
OS10(conf-if-po-20)# ip dhcp snooping trust
OS10(conf-if-po-20)# exit
OS10(config)# interface ethernet 1/1/1,1/1/6
OS10(conf-if-eth1/1/1,1/1/6)# no shutdown
OS10(conf-if-et1/1/1,1/1/6)# channel-group 20
DHCP server
DHCP server configuration
OS10(config)# interface vlan 100
OS10((conf-if-vl-100)# ip address 10.1.1.1/24
OS10((conf-if-vl-100)# exit
OS10(config)# ip dhcp server
OS10(config-dhcp)# no disable
OS10(config-dhcp)# pool dell_server1
OS10(config-dhcp-dell_server1)# lease 0 1 0
OS10(config-dhcp-dell_server1)# network 10.1.1.0/24
OS10(config-dhcp-dell_server1)# range 10.1.1.2 10.1.1.100
Verify DHCP snooping on both VLT peers
220
System management