API Guide

...
!
interface vlan1
no shutdown
!
interface vlan10
no shutdown
!
interface ethernet1/1/1
no shutdown
switchport access vlan 10
!
interface ethernet1/1/2
no shutdown
switchport access vlan 10
!
interface ethernet1/1/3
no shutdown
switchport access vlan 10
!
interface ethernet1/1/4
no shutdown
switchport access vlan 10
Supported
Releases
10.4.0E(R1) or later
description (Interface)
Configures a textual description of an interface.
Syntax
description string
Parameters string Enter a text string for the interface description. A maximum of 240 characters.
Default Not configured
Command Mode INTERFACE
Usage
Information
To use special characters as a part of the description string, enclose the string in double quotes.
Spaces between characters are not preserved after entering this command unless you enclose the
entire description in quotation marks; for example, text description.
Enter a text string after the description command to overwrite any previously configured text
string.
Use the show running-configuration interface command to view descriptions configured
for each interface.
The no version of this command deletes the description.
Example
OS10(conf-if-eth1/1/7)# description eth1/1/7
Supported
Releases
10.2.0E or later
duplex
Configures Duplex mode on the Management port.
Syntax
duplex {full | half | auto}
Parameters
full Set the physical interface to transmit in both directions.
half Set the physical interface to transmit in only one direction.
auto Set the port to auto-negotiate speed with a connected device.
Interfaces 285