API Guide

Enable multicast routing globally and establish PIM neighborship between routers. Ensure that the unicast routing table is
populated.
Ensure that the candidate RP can reach all the nodes in your network.
(Optional) Configure an ACL with source as any and destination as a valid multicast group address. If you do not
configure an ACL, the router advertises itself as the RP for the entire multicast range, which is 224.0.0.0/4.
NOTE:
When you associate an ACL without any rules to an RP candidate, the system behaves differently depending on
the order of the configuration:
- If you create the ACL without any rules first and then associate it with the RP candidate, the router denies all
multicast groups.
- If you associate an ACL to an RP candidate that is not yet created in the system, and then configure the ACL
without any rules, the router advertises itself as the RP for the entire multicast range, 224.0.0.0/4.
Do not use deny rules in the ACL that is used for RP candidate because it does not have any significance.
To configure dynamic RP using the BSR mechanism:
1. Configure a candidate BSR using the ip pim bsr-candidate command.
OS10# configure terminal
OS10(config)# interface ethernet 1/1/9
OS10(conf-if-eth1/1/9)# ip address 10.1.1.8/24
OS10(conf-if-eth1/1/9)# no shutdown
OS10(conf-if-eth1/1/9)# exit
OS10(config)# ip pim bsr-candidate ethernet 1/1/9 hash-mask-len 31 priority 255
To view the PIM candidate and elected BSR:
OS10# show ip pim bsr-router
This system is the Bootstrap Router (v2)
BSR address: 10.1.1.8
BSR Priority: 255, Hash mask length: 31
Next bootstrap message in 00:00:57
This system is a candidate BSR
Candidate BSR address: 11.1.1.8, priority: 255, hash mask length: 31
2. (Optional) Configure the BSR timer.
OS10(config)# ip pim bsr-candidate-timers ethernet 1/1/9 advt-interval 40
To view the BSR timer value:
OS10# show ip pim bsr-router
This system is the Bootstrap Router (v2)
BSR address: 10.1.1.8
BSR Priority: 255, Hash mask length: 31
Next bootstrap message in 00:00:39
This system is a candidate BSR
Candidate BSR address: 11.1.1.8, priority: 255, hash mask length: 31
3. Configure candidate RP.
OS10# configure terminal
OS10(config)# interface loopback 10
OS10(conf-if-lo-10)# ip address 10.1.2.8/24
OS10(conf-if-lo-10)# no shutdown
OS10(conf-if-lo-10)# exit
OS10(config)# ip access-list acl-rp
OS10(config-ipv4-acl)# permit ip any 225.1.1.0/24
OS10(config)# ip pim rp-candidate loopback 10 priority 23 acl acl-rp
NOTE:
The system does not overwrite the candidate RP configuration. You must delete the entry and reconfigure it.
For example, after you configure the candidate RP with priority and associate an ACL with it, to reset the priority and
808 Multicast