Connectivity Guide

interface ethernet1/1/1
no shutdown
no switchport
ip address 172.17.4.1/24
Linux shell commands
You can execute a single command, or a series of commands, using a batch le from the Linux shell.
Use the -c option to run a single command.
admin@OS10:/opt/dell/os10/bin$ clish -c "show version"
New user admin logged in at session 10
Dell EMC Networking OS10 Enterprise
Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.
OS Version: 10.4.3.0
Build Version: 10.4.3.85
Build Time: 2019-02-18T17:06:10-0800
System Type: S4048-ON
Architecture: x86_64
Up Time: 2 days 05:58:01
User admin logged out at session 10
admin@OS10:/opt/dell/os10/bin$
Use the -B option along with a batch le to execute a series of commands.
configure terminal
router bgp 100
neighbor 100.1.1.1
remote-as 104
no shutdown
Execute the batch le.
admin@OS10:/opt/dell/os10/bin$ clish -B ~/batch_cfg.txt
New user admin logged in at session 15
Verify the BGP conguration executed by the batch le.
admin@OS10:/opt/dell/os10/bin$ clish -c "show running-configuration bgp"
New user admin logged in at session 16
!
router bgp 100
!
neighbor 100.1.1.1
remote-as 104
no shutdown
admin@OS10:/opt/dell/os10/bin$
User admin logged out at session 16
SSH commands
You can execute commands remotely using a secure shell (SSH) session. This is supported only for show commands.
Enter the show command along with SSH.
$ ssh admin@ip-address show-command
$ ssh admin@10.11.98.39 "show version"
admin@10.11.98.39's password:
Getting Started
61