Users Guide

Table Of Contents
Enable DHCP snooping globally.
OS10(config)# ip dhcp snooping
VLAN configuration
Create a VLAN and assign an IP address to it which acts as the gateway for the VMs.
OS10# configure terminal
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# no shutdown
OS10(conf-if-vl-100)# ip address
OS10(conf-if-vl-100)# ip address 10.1.1.2/24
OS10(conf-if-vl-100)# exit
Create another VLAN and assign an IP address to it which can communicate with the DHCP server.
OS10# configure terminal
OS10(config)# interface vlan 200
OS10(conf-if-vl-200)# no shutdown
OS10(conf-if-vl-200)# ip address
OS10(conf-if-vl-200)# ip address 10.2.1.3/24
OS10(conf-if-vl-200)# exit
Configure SW 1 as the DHCP relay agent for the clients in the VM. The IP address that you specify here is the IP address of
the DHCP server
OS10# configure terminal
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# ip helper-address 10.2.1.2
VLT configuration
1. Create a VLT domain and configure VLTi.
OS10(config)# interface range ethernet 1/1/4-1/1/5
OS10(conf-range-eth1/1/4-1/1/5)# no switchport
OS10(conf-range-eth1/1/4-1/1/5)# exit
OS10(config)# vlt-domain 1
OS10(conf-vlt-1)# discovery-interface ethernet 1/1/4-1/1/5
2. Configure a VLT MAC address.
OS10(conf-vlt-1)# vlt-mac 12:5e:23:f4:23:54
3. Specify the management IP address of the VLT peer as a backup link.
OS10(conf-vlt-1)# backup destination 10.10.10.1
4. Configure VLT port channels.
SW2 to VM VLT port channel configuration
OS10(config)# interface port-channel 10
OS10(conf-if-po-10)# description SW2ToVM
OS10(conf-if-po-10)# vlt-port-channel 10
OS10(conf-if-po-10)# switchport mode access
OS10(conf-if-po-10)# switchport access vlan 100
OS10(conf-if-po-10)# exit
OS10(config)# interface ethernet 1/1/2-1/1/3
OS10(conf-if-eth1/1/2-1/1/3)# no shutdown
OS10(conf-if-eth1/1/2-1/1/3)# channel-group 10
SW 2 to DHCP server configuration
OS10(config)# interface port-channel 20
OS10(conf-if-po-20)# description SW2ToDHCP-Server
OS10(conf-if-po-20)# vlt-port-channel 20
OS10(conf-if-po-20)# switchport mode trunk
OS10(conf-if-po-20)# switchport trunk allowed vlan 100,200
OS10(conf-if-po-20)# ip dhcp snooping trust
294
System management