Users Guide

Table Of Contents
Spine Switch 2
1. Configure downstream ports on underlay links to leaf switches.
OS10(config)# interface ethernet1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# no switchport
OS10(conf-if-eth1/1/1)# ip address 172.16.2.1/31
OS10(conf-if-eth1/1/1)# ip ospf 1 area 0.0.0.0
OS10(conf-if-eth1/1/1)# exit
OS10(config)# interface ethernet1/1/2
OS10(conf-if-eth1/1/2)# no shutdown
OS10(conf-if-eth1/1/2)# no switchport
OS10(conf-if-eth1/1/2)# ip address 172.17.2.1/31
OS10(conf-if-eth1/1/2)# ip ospf 1 area 0.0.0.0
OS10(conf-if-eth1/1/2)# exit
OS10(config)# interface ethernet1/1/3
OS10(conf-if-eth1/1/3)# no shutdown
OS10(conf-if-eth1/1/3)# no switchport
OS10(conf-if-eth1/1/3)# ip address 172.18.2.1/31
OS10(conf-if-eth1/1/3)# ip ospf 1 area 0.0.0.0
OS10(conf-if-eth1/1/3)# exit
OS10(config)# interface ethernet1/1/4
OS10(conf-if-eth1/1/4)# no shutdown
OS10(conf-if-eth1/1/4)# no switchport
OS10(conf-if-eth1/1/4)# ip address 172.19.2.1/31
OS10(conf-if-eth1/1/4)# ip ospf 1 area 0.0.0.0
OS10(conf-if-eth1/1/4)# exit
2. Configure the underlay OSPF protocol.
OS10(config)# router ospf 1
OS10(config-router-ospf-1)# router-id 172.201.0.1
OS10(config-router-ospf-1)# exit
BGP EVPN for VXLAN
Ethernet Virtual Private Network (EVPN) is a control plane for VXLAN that reduces flooding in the network and resolves
scalability concerns. EVPN uses MP-BGP to exchange information between VTEPs. EVPN was introduced in RFC 7432 and is
based on BGP MPLS-based VPNs. RFC 8365 describes VXLAN-based EVPN.
The MP-BGP EVPN control plane provides protocol-based remote VTEP discovery, and MAC and ARP learning. This
configuration reduces flooding related to L2 unknown unicast traffic. The distribution of host MAC and IP reachability
information supports virtual machine (VM) mobility and scalable VXLAN overlay network designs.
The BGP EVPN protocol groups MAC addresses and ARP/neighbor addresses under EVPN instances (EVIs) to exchange them
between VTEPs. In OS10, each EVI is associated with a VXLAN VNI in 1:1 mapping.
Benefits of a BGP EVPN-based VXLAN
Eliminates the flood-and-learn method of VTEP discovery by enabling control-plane learning of end-host L2 and L3
reachability information.
Minimizes network flooding of unknown unicast and broadcast traffic through EVPN-based MAC and IP route
advertisements on local VTEPs.
Provides support for host mobility.
BGP EVPN compared to static VXLAN
OS10 supports two types of VXLAN NVO overlay networks:
Static VXLAN
BGP EVPN
VXLAN
973