Users Guide

Table Of Contents
PIM-SM sample configuration
This section describes how to enable PIM-SM in the FHR, RP, and LHR nodes using the topology show in the following figure.
To enable PIM-SM, perform the following configurations on each of the nodes (FHR, RP, and LHR):
1. Enable multicast routing globally in CONFIGURATION mode.
ip multicast-routing
2. Enable PIM-SM on the required Layer 3 interfaces of the nodes in INTERFACE mode.
ip pim sparse-mode
3. Configure an RP address on every multicast-enabled node in CONFIGURATION mode.
ip pim rp-address
4. Configure an IP address for each interface of the nodes in the PIM-SM topology in INTERFACE mode.
ip address A.B.C.D/prefix-length
5. Enable a routing protocol (OSPF) for route updates in INTERFACE mode.
ip ospf ospf-instance area area-address
Sample configuration in FHR node:
FHR# configure terminal
FHR(config)#
FHR(config)# ip multicast-routing
FHR(config)# interface ethernet 1/1/31
FHR(conf-if-eth1/1/31)# no switchport
FHR(conf-if-eth1/1/31)# ip address 3.3.3.2/24
FHR(conf-if-eth1/1/31)# ip pim sparse-mode
FHR(conf-if-eth1/1/31)# ip ospf 1 area 0
FHR(conf-if-eth1/1/31)# exit
FHR(config)#
FHR(config)# interface ethernet 1/1/17
FHR(conf-if-eth1/1/17)#
FHR(conf-if-eth1/1/17)# no switchport
FHR(conf-if-eth1/1/17)# ip address 2.2.2.2/24
FHR(conf-if-eth1/1/17)# ip pim sparse-mode
FHR(conf-if-eth1/1/17)# ip ospf 1 area 0
FHR(conf-if-eth1/1/17)# exit
FHR(config)# router ospf 1
FHR(config-router-ospf-1)# exit
FHR(config)# ip pim rp-address 192.168.1.25 group-address 224.0.0.0/4
FHR(config)#
FHR# configure terminal
FHR(config)# interface ethernet 1/1/48
Multicast
1061