Users Guide

Table Of Contents
If the DHCP server is reachable on a different VRF, configure route leaking on VRF hello to reach the DHCP server.
In the above case, as there is no virtual anycast IP, the server-override option value is not added. As a result, further DHCP
packets from the client directly go to the server.
DHCP Relay Agent
Global config:
ip dhcp-relay server-override
ip dhcp-relay link-selection
ip dhcp-relay vss
VRF config for source-interface:
OS10# show running-configuration vrf
!
ip vrf default
update-source-ip loopback0
ip dhcp-relay source-interface loopback0
!
ip vrf hello
update-source-ip loopback1
ip dhcp-relay source-interface loopback0
interface loopback1
ip vrf forwarding hello
no shutdown
ip address 5.1.1.1/32
interface loopback0
no shutdown
ip address 3.1.1.1/32
!
interface Ethernet 1/1/1
no shutdown
ip address 1.1.1.1/24
ip helper-address 20.1.1.2
!
interface Ethernet 1/1/2
no shutdown
ip address 20.1.1.1/24
!
interface Ethernet 1/1/3
no shutdown
ip vrf forwarding hello
ip address 1.1.1.1/24
ip helper-address 30.1.1.2 vrf hello
ip dhcp-relay vss-info type 0 serverVRF
!
interface Ethernet 1/1/4
no shutdown
ip vrf forwarding hello
ip address 30.1.1.1/24
DHCP-SERVER#show running-config ip dhcp pool
ip vrf serverVRF
vpn id 463130:56524632
!
ip dhcp pool hello_clients
vrf serverVRF
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
System management
271