Users Guide

Table Of Contents
3. Return to CONFIGURATION mode.
exit
4. Enter Interface breakout mode to configure other settings, such as, speed.
interface ethernet node/slot/port[:subport]
The following shows converting a port group from 25g-4x mode to 10g-4x mode:
OS10# configure terminal
OS10(config)# port-group 1/1/1
OS10(conf-pg-1/1/1)# mode Eth 10g-4x
OS10(conf-pg-1/1/1)# exit
OS10(config)# interface ethernet 1/1/1:1
OS10(conf-if-eth1/1/1:1)# speed
1000 Set speed to 1000 Mbps
10000 Set speed to 10000 Mbps
auto Automatic Settings (default)
OS10(conf-if-eth1/1/1:1)# speed 1000
L2 mode configuration
Each physical Ethernet interface uses a unique MAC address. Port-channels and VLANs use a single MAC address. By default,
all the interfaces operate in L2 mode. From L2 mode you can configure switching and L2 protocols, such as VLANs and
Spanning-Tree Protocol (STP) on an interface.
Enable L2 switching on a port interface in Access or Trunk mode. By default, an interface is configured in Access mode. Access
mode allows L2 switching of untagged traffic on a single VLAN (VLAN 1 is the default). Trunk mode enables L2 switching of
untagged traffic on the Access VLAN, and tagged traffic on one or more VLANs.
By default, native VLAN of a port is the default VLAN ID of the switch. You can change the native VLAN using the
switchport access vlan vlan-id command.
A Trunk interface carries VLAN traffic that is tagged using 802.1q encapsulation. If an Access interface receives a packet with
an 802.1q tag in the header that is different from the Access VLAN ID, it drops the packet.
By default, a trunk interface carries only untagged traffic on the Access VLAN. You must manually configure other VLANs for
tagged traffic.
1. Select one of the two available options:
Configure L2 trunking in INTERFACE mode and the tagged VLAN traffic that the port can transmit. By default, a trunk
port is not added to any tagged VLAN. You must create a VLAN before you can assign the interface to it.
switchport mode trunk
switchport trunk allowed vlan vlan-id-list
Reconfigure the access VLAN assigned to a L2 access or trunk port in INTERFACE mode.
switchport access vlan vlan-id
2. Enable the interface for L2 traffic transmission in INTERFACE mode.
no shutdown
L2 interface configuration
OS10(config)# interface ethernet 1/1/7
OS10(conf-if-eth1/1/7)# switchport mode trunk
OS10(conf-if-eth1/1/7)# switchport trunk allowed vlan 5,10
OS10(conf-if-eth1/1/7)# no shutdown
Interfaces
347