Users Guide

Table Of Contents
Figure 9. Route leaking between VRFs with asymmetric IRB routing
For VXLAN-related configurations, see Configure VXLAN. To configure route leaking between VRFs with asymmetric IRB
routing:
VTEP1
1. Configure IP helper address specifying the DHCP server ip address in the client-connected virtual networks with the
client-connected VRF name. For IPv6 DHCP helper address, specify the server VRF in the helper-address command.
VTEP1(config)# interface virtual-network 10
VTEP1(conf-if-vn-10)# ip helper-address 20.1.1.100 vrf GREEN
2. Configure loopback interfaces. Assign the loopback interfaces as source interfaces for the VRF.
VTEP1(config)# interface loopback 2
VTEP1(conf-if-lo-2)# ip vrf forwarding GREEN
VTEP1(conf-if-lo-2)# ip address 51.1.1.1/32
VTEP1(conf-if-lo-2)# exit
VTEP1(config)# interface loopback 3
VTEP1(conf-if-lo-3)# ip vrf forwarding RED
VTEP1(conf-if-lo-3)# ip address 52.1.1.1/32
VTEP1(conf-if-lo-3)# exit
VTEP1(config)# ip vrf GREEN
VTEP1(conf-vrf)# update-source-ip loopback 2
VTEP1(conf-vrf)# exit
VTEP1(config)# ip vrf RED
VTEP1(conf-vrf)# update-source-ip loopback 3
VTEP1(conf-vrf)# exit
3. Leak the server-connected networks to the tenant VRF to which the client is connected.
VTEP1(config)# ip route vrf GREEN 20.1.1.0/24 interface virtual-network 20
VTEP1(config)# ip route vrf GREEN 52.1.1.1/32 interface loopback 3
4. Leak the client-connected networks to the tenant VRF to which the server is connected.
VTEP1(config)# ip route vrf RED 10.1.1.0/24 interface virtual-network 10
VTEP1(config)# ip route vrf RED 51.1.1.1/32 interface loopback 2
734
Layer 3