Users Guide

Table Of Contents
VTEP2
1. Configure IP helper address specifying the DHCP server ip address in the client-connected virtual networks with the
client-connected VRF name. For IPv6 DHCP helper address, specify the server VRF in the helper-address command.
VTEP2(config)# interface virtual-network 10
VTEP2(conf-if-vn-10)# ip helper-address 20.1.1.100 vrf GREEN
2. Configure loopback interfaces. Assign the loopback interfaces as source interfaces for the VRF.
VTEP2(config)# interface loopback 2
VTEP2(conf-if-lo-2)# ip vrf forwarding GREEN
VTEP2(conf-if-lo-2)# ip address 51.1.1.2/32
VTEP2(conf-if-lo-2)# exit
VTEP2(config)# interface loopback 3
VTEP2(conf-if-lo-3)# ip vrf forwarding RED
VTEP2(conf-if-lo-3)# ip address 52.1.1.2/32
VTEP2(conf-if-lo-3)# exit
VTEP2(config)# ip vrf GREEN
VTEP2(conf-vrf)# update-source-ip loopback 2
VTEP2(conf-vrf)# exit
VTEP2(config)# ip vrf RED
VTEP2(conf-vrf)# update-source-ip loopback 3
VTEP2(conf-vrf)# exit
3. Leak the server-connected networks to the tenant VRF to which the client is connected.
VTEP2(config)# ip route vrf GREEN 20.1.1.0/24 interface virtual-network 20
VTEP2(config)# ip route vrf GREEN 52.1.1.2/32 interface loopback 3
4. Leak the client-connected networks to the tenant VRF to which the server is connected.
VTEP2(config)# ip route vrf RED 10.1.1.0/24 interface virtual-network 10
VTEP2(config)# ip route vrf RED 51.1.1.2/32 interface loopback 2
Route leaking
Route leaking enables routes that are configured in the default or a nondefault VRF instance to be made available to another
VRF instance. You can leak routes from a source VRF instance to a destination VRF instance.
OS10 supports leaking routes for static and dynamic routes. The leaked routes retain the type of the route, whether they are
static, OSPF, BGP, or connected routes in the destination VRF. For example, leaked OSPF routes from one VRF are imported as
OSPF routes in the destination VRF. You can use a route map for route filtering when importing routes to a VRF.
The routes must be leaked in both source and destination VRFs to achieve end-to-end traffic flow.
NOTE: Dell EMC networking recommends configuring unique route targets in every VRF.
Restrictions for route leaking
BFD attributes are not carried over to a leaked static route. If BFD removes a static route from the VRF that leaks the route,
the leaked route is removed from the VRF that imports it. When the static route is restored in the VRF that leaks the route,
the leaked route is restored in the VRF that imports it.
Using route targets does not leak /32 prefixes on loopback interfaces. You can use static route leaking to leak /32 prefixes
on loopback interfaces.
The following lists the maximum number of leaked routes supported by the system with ECMP:
4000 IPv4 routes and 2000 IPv6 routes with 64 ECMP paths.
2000 IPv4 routes and 1000 IPv6 routes with 128 ECMP paths.
Table 84. Unsupported export and import route map attributes
Layer 3 735