Users Guide

Table Of Contents
The no version of this command disables the BGP neighbor configuration.
Example
The following is an example for configuring an unnumbered BGP neighbor:
OS10(config)# interface vlan 100
OS10(conf-if-vl-100)# ipv6 nd max-ra-interval 4
OS10(conf-if-vl-100)# ipv6 nd min-ra-interval 3
OS10(conf-if-vl-100)# ipv6 nd send-ra
OS10(conf-if-vl-100)# exit
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# switchport mode trunk
OS10(conf-if-eth1/1/1)# switchport trunk allowed vlan 100
OS10(config)# router bgp 100
OS10(config-router-bgp-100)# neighbor interface vlan 100
OS10(config-router-neighbor)# no shutdown
The following is an example for configuring an auto unnumbered BGP neighbor:
OS10# configure terminal
OS10(config)# ipv6 nd max-ra-interval 4
OS10(config)# ipv6 nd min-ra-interval 3
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# no shutdown
OS10(conf-if-eth1/1/1)# no switchport
OS10(conf-if-eth1/1/1)# ipv6 nd send-ra
OS10(conf-if-eth1/1/1)#ipv6 bgp unnumbered ebgp-template
OS10(conf-if-eth1/1/1)#exit
OS10(config)# router bgp 100
OS10(config-router-bgp-100)# neighbor unnumbered-auto
OS10(config-router-neighbor)# no shutdown
Supported
Releases
10.3.0E or later
network
Configures a network as local to this AS and adds it to the BGP routing table.
Syntax
network ip-address/prefix [route-map map-name]
Parameters
ip-address/prefixEnter the IPv4 or IPv6 address and the prefix number to the network.
route-map map-name(Optional) Enter the name of an established route-map.
Defaults None
Command Modes ROUTER-AF
Usage
Information
The no version of this command removes the network.
Example
OS10(conf-router-bgpv4-af)#
OS10(config-router-bgp-64601)# address-family ipv4 unicast
OS10(configure-router-bgpv4-af)# network 192.168.1.0/24
OS10(configure-router-bgpv4-af)# do commit
Supported
Releases
10.3.0E or later
next-hop-self
Configures the next-hop-self support for the peer-group level. This support applies for both IPv4 and IPv6 address families.
Syntax
next-hop-self
Layer 3 861