Specifications

Intro introduction to kernel data structures and properties
Section 9P describes kernel properties used by device drivers. Section 9S describes the
data structures used by drivers to share information between the driver and the
kernel. See Intro(9E) for an overview of device driver interfaces.
In Section 9S, reference pages contain the following headings:
NAME summarizes the purpose of the structure or property.
SYNOPSIS lists the include le that denes the structure or property.
INTERFACE LEVEL describes any architecture dependencies.
DESCRIPTION provides general information about the structure or property.
STRUCTURE MEMBERS lists all accessible structure members (for Section 9S).
SEE ALSO gives sources for further information.
Of the preceding headings, Section 9P reference pages contain the NAME,
DESCRIPTION, and SEE ALSO elds.
Every driver MUST include <sys/ddi.h> and <sys/sunddi.h>, in that order, and
as nal entries.
The following table summarizes the STREAMS structures described in Section 9S.
Structure Type
copyreq DDI/DKI
copyresp DDI/DKI
datab DDI/DKI
fmodsw Solaris DDI
free_rtn DDI/DKI
iocblk DDI/DKI
linkblk DDI/DKI
module_info DDI/DKI
msgb DDI/DKI
qband DDI/DKI
qinit DDI/DKI
queclass Solaris DDI
queue DDI/DKI
streamtab DDI/DKI
stroptions DDI/DKI
Intro(9S)
NAME
DESCRIPTION
14 man pages section 9: DDI and DKI Properties and Data Structures Last Revised 15 May 2001