aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
ARIES Performance Tuning
Users may find following tips useful for tuning the performance of their PA-RISC applications under
ARIES:
1. For applications which are very much loop intensive, reduce the ARIES translation threshold value
(ARIES option
-ts).
2. For applications that run for a long duration and have good locality of execution (few functions
account for significant portion of total execution time), you may consider enabling trace scheduling
(ARIES option flag
-sched_trace).
3. If trace scheduling is enabled, you may consider fine tuning the trace scheduling threshold (ARIES
option
-ts_trace).
4. For long running Java applications that have large methods, consider increasing the size of ARIES
AMAP for dynamically generated code (ARIES option
-amapsz_smc
).
5. For some rare applications that access and modify the Floating Point Access Register (FPSR : fr0L)
register in a loop, consider enabling translations for such blocks (ARIES option flag
-fpgr_trans).
6. Some applications experience good performance if ARIES maps emulated FP register context on gen-
eral registers. While others would perform well if this optimization is disabled. Consider changing
the ARIES option flag
-[no]opt_fpgr.
7. Some applications may show slight performance gain if re-ordering of state changing instructions and
memory loads is enabled (ARIES option flag
-[no]opt_reorder
).
WARNING: Some multi-threaded applications like JVM might fail with core dump if ARIES re-
orders state changing PA-RISC instructions.
8. Some applications that have large text segment size or load many shared libraries may require large
code cache region size (ARIES option
-descsz, -amapsz, -ccsz). For best results make sure that
sizes of these parameters are in the ratio 1:2:2.
9. Some applications that require ARIES to spend significant time in dynamic translations may work
faster if translations are cached (ARIES option
-load, -save). The save and load of translated
code works best for statically linked applications.
WARNING: Some PA-RISC applications may not work correctly with the loading of ARIES dynamic
translations cached on disk during previous executions of the same application.
ARIES SUPPORTED APPLICATIONS
ARIES supports emulation of all well-behaved (those applications that do not use un-documented
features) PA-RISC HP-UX applications and that run fine on latest HP-UX version on PA-RISC sys-
tems.
ARIES supports all HP-UX Inter-Process Communication mechanisms such as semaphores, pipes,
shared memory, and sockets, between Integrity native and emulated PA-RISC processes.
The exact signal/exception behavior of PA-RISC HP-UX applications, is supported under ARIES.
There is only a very small subset of the PA-RISC application domain that are not supported under
ARIES.
To ascertain whether a particular application will run correctly under ARIES or not, determine if the
application falls into one of the ARIES limitations described in the ARIES LIMITATIONS section in
this manpage.
ARIES LIMITATIONS
ARIES supports emulation of all PA-RISC HP-UX applications, with the following limitations and/or
exceptions:
1. ARIES does not support PA-RISC applications that load Integrity native shared libraries. ARIES is
meant only for pure PA-RISC HP-UX applications that are either statically or dynamically linked
with PA-RISC libraries only.
2. The version of ARIES at this release supports PA-RISC HP-UX applications that run fine on contem-
porary HP-UX release version on native PA-RISC systems.
3. ARIES does not support privileged PA-RISC instructions. Hence, device drivers and loadable kernel
modules are not supported.
14 Hewlett-Packard Company 14 HP-UX 11i Version 3: September 2010