aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
The default state of this option flag is enabled (
-opt_fpgr).
-[no]opt_reorder
[Disables] enables the ARIES optimizations for dynamically translated code to re-order
PA-RISC state changing instructions, loads, and updates to general registers in order to
achieve better scheduling of translated code.
WARNING: Do not enable (
-opt_reorder) this option flag with multi-threaded applica-
tions like JVM which expect precise delivery of synchronous exceptions and register updates.
Such applications may crash with core file if this option flag is enabled (
-opt_reorder).
The default state of this option flag is disabled (
-noopt_reorder
).
-[no]pa_os_cpu
[Disables] enables the emulation of the uname()
and sysconf() system calls, to return
information specific to native PA-RISC HP-UX systems. See uname(2) and sysconf (2).
Enable (
-pa_os_cpu) this option flag only if the PA-RISC application expects the return
values of uname() and sysconf() system calls, to be specific to the values that would have
been obtained if the application was running on PA-RISC HP-UX system.
The default state of this option flag is disabled (
-nopa_os_cpu).
-[no]sched_trace
[Disables] enables the trace scheduling and low level optimization of ARIES translated code.
NOTE: Enabling (
-sched_trace) this option flag may provide improved performance for
compute intensive applications.
The default state of this option flag is disabled (
-nosched_trace
).
-[no]trans
[Disables] enables the dynamic translation in ARIES. Disabling (-notrans) this option flag
is useful only for triaging of dynamic translator failures.
WARNING: Disabling (
-notrans) this option flag will cause significant performance slow-
down.
The default state of this option flag is enabled (
-trans).
-[no]unsafetrans
[Disables] enables the dynamic translation of self modifying (dynamically generated) code.
Disabling (-nounsafetrans
) this option flag is useful only for triaging of Java-based appli-
cation failures under ARIES.
WARNING: Disabling (
-nounsafetrans
) this option flag will cause significant perfor-
mance slowdown for Java-based applications.
The default state of this option flag is enabled (
-unsafetrans).
-amapsz { size | default }
Size in kbytes of the total memory area to be used for ARIES address map (AMAP) data struc-
tures, for mappings between PA-RISC basic blocks and translated code addresses.
Value 32-bit ARIES 64-bit ARIES
Default: 16384 KB (16 MB) 24576 KB (24 MB)
Max: 65536 KB (64 MB) 98304 KB (96 MB)
Min: 8192 KB ( 8 MB) 8192 KB ( 8 MB)
NOTE: To minimize the performance drop due to increased frequency of ARIES AMAP area
overflow, HP recommends setting this option value at the default or maximum size.
For optimal performance, a ratio of 1:2:2 should be maintained for the values of the ARIES
options:
-descsz, -amapsz, and -ccsz.
-amapsz_smc { size | default }
Size in kbytes of the memory area used for ARIES address map (AMAP) data structures
corresponding to dynamic translations of self modifying code of PA-RISC application. This
area is part of the memory region whose size is determined by the ARIES option -amapsz.
6 Hewlett-Packard Company 6 HP-UX 11i Version 3: September 2010