glossary.9 (2010 09)

p
glossary(9) glossary(9)
returned to the system, although some resources, such as the process ID are still in use. When another
process executes a
wait(), wait3(),or
waitpid() function (see wait(2)) for an inactive process, the
remaining resources are returned to the system. The last resource to be returned to the system is the
process ID. At this time, the lifetime of the process ends.
program
A sequence of instructions to the computer in the form of binary code (resulting from the compilation and
assembly of program source).
prompt
The characters displayed by the shell on the terminal indicating that the system is ready for a command.
The prompt is usually a dollar sign (
$) for ordinary users (% in the C shell) and a pound sign (#
) for the
superuser, but you can redefine it to be any string by setting the appropriate shell variable (see sh(1) and
related entries). See also secondary prompt.
quit signal
The
SIGQUIT signal (see signal (2). The quit signal is generated by typing the character defined by the
teletype handler as your quit signal. (See stty (1), ioctl (2), and termio (7).) The default is the ASCII FS
character (ASCII value 28) generated by typing Ctrl-
\. This signal usually causes a running program to
terminate and generates a file containing the "core image" of the terminated process. The core image is
useful for debugging purposes. (Some systems do not support core images, and on those systems no such
file is generated.)
radix character
The character that separates the integer part of a number from the fractional part. For example, in
American usage, the radix character is a decimal point, while in Europe, a comma is used.
raw disk
The name given to a disk for which there exists a character special file that allows direct transmission
between the disk and the user’s read or write buffer. A single read or write call results in exactly one I/O
call.
read-only file system
A characteristic of a file system that prevents file system modifications.
real group ID
A positive integer which is assigned to every user on the system. The association of a user and his or her
real group ID is done in the file
/etc/passwd. The modifier "real" is used because a user can also
have an effective group ID. The real group ID can then be mapped to a group name in the file
/etc/group, although it need not be. Thus, every user is a member of some group (which can be name-
less), even if that group has only one member.
Every time a process creates a child process (via fork (2)), that process has a real group ID equal to the
parent process’s real group ID. This is useful for determining file access privileges within the process.
real user ID
A positive integer which is assigned to every user on the system. A real user ID is assigned to every valid
login name in the file /etc/passwd. The modifier "real" is used because a user can also have an
effective user ID (see effective user ID).
Every time a process creates a child process (via fork(2)), that process has a real user ID equal to the
parent process’s real user ID. This is useful for determining file access privileges within the process.
regular expression
A string of zero or more characters that selects text. All the characters contained in the string might be
literal, meaning that the regular expression matches itself only; or one or more of the characters might be
a metacharacter, meaning that a single regular expression could match several literal strings. Regular
expressions are most often encountered in text editors (such as ed(1), ex(1), or vi (1)), where searches are
performed for a specific piece of text, or in commands that were created to search for a particular string
in a file (most notably grep(1)). Regular expressions are also encountered in the shell, especially when
referring to file names on command lines.
18 Hewlett-Packard Company 18 HP-UX 11i Version 3: September 2010