User Manual

Pre-marking cannot be used in conjunction with the set egress queue function.
[Example]
Make the following settings for received frames of LAN port #1
Permit traffic from the 10.1.0.0 network
Change the classified traffic class to the CoS value "2"
[Traffic class definition]
SWR2311P(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any
SWR2311P(config)#class-map class1
SWR2311P(config-cmap)#match access-list 1
SWR2311P(config-cmap)#exit
[Policy settings]
SWR2311P(config)#policy-map policy1
SWR2311P(config-pmap)#class class1
SWR2311P(config-pmap-c)#set cos 2
SWR2311P(config-pmap-c)#exit
SWR2311P(config-pmap)#exit
SWR2311P(config)#interface port1.1
SWR2311P(config-if)#service-policy input policy1
9.2.24 Set pre-marking (TOS precedence)
[Syntax]
set ip-precedence value
no set ip-precedence
[Parameter]
value : <0 - 7>
TOS precedence to specify by pre-marking
[Input mode]
policy map class mode
[Description]
Changes the value of the IP header's TOS precedence field of the classified traffic class to the specified TOS value. In addition,
reassign the egress queue according to the egress queue ID table that corresponds to the trust mode.
If this is executed with the "no" syntax, pre-marking processing of the TOS precedence corresponding to the traffic class is
removed.
[Note]
In order to execute this command, QoS must be enabled.
Pre-marking cannot be used in conjunction with the set egress queue function.
[Example]
Make the following settings for received frames of LAN port #1
Permit traffic from the 10.1.0.0 network
Change the classified traffic class to TOS precedence "5".
[Traffic class definition]
SWR2311P(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any
SWR2311P(config)#class-map class1
SWR2311P(config-cmap)#match access-list 1
SWR2311P(config-cmap)#exit
[Policy settings]
SWR2311P(config)#policy-map policy1
SWR2311P(config-pmap)#class class1
SWR2311P(config-pmap-c)#set ip-precedence 5
SWR2311P(config-pmap-c)#exit
SWR2311P(config-pmap)#exit
SWR2311P(config)#interface port1.1
SWR2311P(config-if)#service-policy input policy1
Command Reference | Traffic control | 261