audit_dpms_filter.4 (2010 09)

a
audit_dpms_filter(4) audit_dpms_filter(4)
NAME
audit_dpms_filter - configuration file for filtering Audit DPMS data
DESCRIPTION
An Audit DPMS filter file specifies filtering rules for selecting auditing information on an event basis
through the Audit DPMS APIs (see audit_dpms (5)). The filter file is registered through the
audit_dpms_register_filter()
interface and can be applied to either reading or writing of the
audit events (see audit_dpms_api(3)).
Each filter file may contain one or more filters. If no filter is specified, all audit events are selected.
Each filter in the file must begin with the
[filter] token, followed by one or more filtering rules. The
[filter] token must be specified literally; it is not optional. During reading or writing of an audit
event, each filter in the file is applied one at time. The Audit DPMS framework considers that the given
audit event satisfies the filtering rules as long as it satisfies one of the filters.
Each filtering rule consists of an action and one or more filtering expressions on which the logical OR is
performed. An action specifies whether or not to include or exclude the event from the selection. The
filtering expressions specify a set of conditions, and based on those conditions, the Audit DPMS frame-
work determines whether or not to apply the action.
Each filtering rule is separated by a semicolon (
;), or a new line, or both. If both include and exclude
actions are specified in a filter, then all of the include expressions (conditions) are processed first, and
then excluded as per the specified exclude expressions (conditions).
Each filtering expression (condition) is a triplet of an attribute keyword, an operator and a value.
Filter Syntax
Here is the syntax of the filter file. All keywords are case sensitive.
filter_file: {filter }*
filter:
[filter]
{filter_rule }+
filter_rule: action conditions [
;]?
action:
include | exclude | + | -
conditions: condition ( || condition)*
condition: attribute operator value
where:
( )* The asterisk
* means zero or more occurrences.
[ ]? The question mark
? means zero or one occurrence.
{ }+ The plus sign
+ means one or more occurrence.
The filter file is preprocessed with
cpp before parsing. You can use cpp directives such as #include,
#define, #ifdef, and C/C++ style comments to organize and document the filters. See cpp (1). The
/etc/audit/dpms_filters directory is used as the default search path for #include directives
that use relative paths.
Syntax errors in the filter file must be corrected before processing new filter files.
audit_dpms_register_filter() will not process new filter files if it encountered a syntax error on
a previously processed filter file.
Conditions
Each filtering expression (condition) is a triplet of:
an attribute keyword,
an operator, and
avalue.
Only the events that match the given condition are selected for further actions (either include or exclude).
See more information about each supported condition type in the following sections, indexed by the attri-
bute keywords.
keyword timestamp
This condition specifies a time period. Only the audit events that occurred during the specified time
period will be considered for action. A time period is specified in the form:
HP-UX 11i Version 3: September 2010 1 Hewlett-Packard Company 1

Summary of content (6 pages)