filecache_max.5 (2010 09)

f
filecache_max(5) filecache_max(5)
(Tunable Kernel Parameters)
To discriminate in favor of deterministic I/O on systems with large file I/O activity, or on the contrary, to
discriminate in favor of better performance of non-I/O-intensive processes, you can consider changing the
values of these tunables, keeping in mind the side effects as described below.
To determine a reasonable value for the cache size you should consider the file I/O-intensive applications
on your system, and the size of their working set. Depending on the type of applications, the working set
size can be based on the size of a transaction, or data size in given unit of time. For example, for a con-
servative value of
filecache_min
in megabytes, you can use the following formula:
MB = number-of-system-processes
* largest-application-record-length-in-MB
* number-of-
records-in-working-set
Only those processes that actively use disk I/O for file data should be included in the calculation. All oth-
ers can be excluded. Here are some examples of what processes should be included in or excluded from
the calculation.
Include:
NFS daemons, text formatters, database management applications, text editors, compilers, and so
on, that access or use source and/or output files stored in one or more file systems mounted on the
system.
Exclude:
X-display applications,
hpterm,
rlogin, login shells, system daemons, telnet or uucp connec-
tions, and so on. These processes use very little, if any, disk I/O for file data.
Restrictions on Changing
These tunables are dynamic and automatic.
The system rounds the specified tunable value(s) down to the closest physical page boundary.
The amount of physical memory represented by
filecache_min
must be equal to or less than the
memory represented by tunable
filecache_max
.
Setting these tunables to a constant value will de-couple them from OL* events.
Tuning up of the
filecache_min
parameter may fail if there is not enough free physical memory to
satisfy the request.
These tunables,
filecache_min and
filecache_max, must both be set to a relative state (either
default of percent state), or must both be set to a constant value. For example, the following are accept-
able settings:
# kctune filecache_min=100MB filecache_max=100MB
# kctune filecache_min=15% filecache_max=65%
# kctune filecache_min=Default filecache_max=65%
The following will result in an error:
# kctune filecache_min=10% filecache_max=1GB
ERROR: The specified units for the values of filecache_min and
filecache must be consistent: both as relative (percentage or
default) or both as constant value.
If filecache_min is currently set to default, the following is acceptable:
# kctune filecache_max=Default
# kctune filecache_max=40%
But the following will result in an error:
# kctune filecache_max=1GB
See other restrictions in the Allowed values section above.
When Should the Value of These Tunables Be Raised?
Low system performance at initialization time and/or on a system with filesystem I/O-intensive processes
may be an indication that the values of these tunables are too low. If there is a large number of processes
actively and constantly using file data I/O, you should raise the value of
filecache_min for more
deterministic I/O. In most cases, especially when the file data I/O is expected to peak only occasionally, it
is recommended that the value of the maximum limit, filecache_max, is raised instead.
2 Hewlett-Packard Company 2 HP-UX 11i Version 3: September 2010