make_net_recovery.1m (2012 03)

m
make_net_recovery(1M) make_net_recovery(1M)
International Code Set Support
Ignite-UX uses a variety of system commands to accomplish its functionality. Because the output of many
of these commands is parsed, Ignite-UX ensures that the POSIX locale is normally used by modifying
environment variables. Help text and some command output not parsed by Ignite-UX will be left in the
user’s specified locale.
RETURN VALUE
make_net_recovery
returns the following values:
0 No warnings or failures occurred; the execution completed successfully.
1 A failure occurred.
2 A warning occurred.
EXAMPLES
Since
make_net_recovery
actually runs on the client instead of the server, all examples have the
-s
server command-line option. This option is required for the command, so that the client (local system)
will know what system to contact as the Ignite-UX server.
Create a system recovery archive by interacting with the Ignite-UX GUI from the Ignite-UX server:
export DISPLAY=hostname :0
ignite
Create a system recovery archive from the client, using settings from the last invocation of the Ignite-UX
GUI:
make_net_recovery -s
myserver
Create a system recovery archive with all the files/directories on the disk(s)/volume group(s) containing
the files specified by the default essentials file list
/opt/ignite/recovery/mnr_essentials
or
the user-defined version of this file, that replaces this file,
/var/opt/ignite/recovery/mnr_essentials
:
make_net_recovery -s
myserver -A
Create a system recovery archive that includes files from all file systems in the vg00
volume group:
make_net_recovery -s
myserver -x inc_entire=vg00
Create a system recovery archive that includes all of the vg00 and vg01 volume groups, but that
excludes the /depots directory:
make_net_recovery -s
myserver -x inc_entire=vg00 -x inc_entire=vg01
-x exclude=/depots
Preview the creation of the System Recovery Archive:
make_net_recovery -p
Use the -u option to have the Ignite-UX software automatically updated when needed from the Ignite
server:
make_net_recovery -s myserver -A -u
This example assumes that the /var/opt/ignite/depots/recovery_cmds
software depot
has been created on the Ignite server. This depot is created by running the
ignite GUI at least
once to make a recovery archive of a system or by running pkg_rec_depot (see also
pkg_rec_depot (1M)). Once created, this depot will automatically be updated each time Ignite-UX is
updated on the server.
Use the
-x option to pass arguments to the print_manifest command. In this example the -d
option will be passed so that disk capacity collection via diskinfo is skipped to improve performance.
Also the -e option will be passed which causes the output file to be printed with HP-PCL3 control codes
for enhanced printer output.
make_net_recovery -s myserver -A -x print_manifest_args="-de"
WARNINGS
6 Hewlett-Packard Company 6 HP-UX 11i Version 3: March 2012